From 85541b187f8bfdae7dda7181ed2bade250efdc5c Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Leo=20Bl=C3=B6cher?= Date: Mon, 26 Oct 2026 17:25:09 +0000 Subject: [PATCH 1/2] fix: Allow libc <0.2.190 again for compatibility with quiche Putting the version requirement at 0.2.191 breaks compatibility with crates that set a requirement of <0.2.190 (like quiche). Cargo doesn't allow excluding specific versions, so the next best thing we can do is switch back to our old version requirement now that `libc 0.2.191` exists. While this does allow a known-incompatible version, cargo won't select it unless someone explicitly asks for it. Meanwhile allowing lower versions makes foundations compatible with repos that need to stick to versions <0.2.190 for other reasons, such as compatibility with `nix` (which has not released a libc 0.2.191-compatible version yet.) --- Cargo.toml | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Cargo.toml b/Cargo.toml index e97f4992..71fcd33d 100644 --- a/Cargo.toml +++ b/Cargo.toml @@ -63,7 +63,7 @@ hyper = { version = "1.9.0", default-features = false } hyper-util = { version = "0.1.20", default-features = false } indexmap = "2.14.0" ipnetwork = { version = "0.21.1", features = ["serde"] } -libc = "0.2.191" +libc = "0.2.186" matchit = "0.9.2" nix = "0.31.2" once_cell = "1.21.4" From ef6e754b21ca1eccd64e624694f68d37f017e9a8 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Leo=20Bl=C3=B6cher?= Date: Mon, 26 Oct 2026 17:31:10 +0000 Subject: [PATCH 2/2] chore: Release --- Cargo.toml | 6 +++--- RELEASE_NOTES.md | 3 +++ 2 files changed, 6 insertions(+), 3 deletions(-) diff --git a/Cargo.toml b/Cargo.toml index 71fcd33d..52baf014 100644 --- a/Cargo.toml +++ b/Cargo.toml @@ -11,7 +11,7 @@ members = [ resolver = "3" [workspace.package] -version = "5.11.1" +version = "5.11.2" repository = "https://github.com/cloudflare/foundations" edition = "2024" authors = ["Cloudflare"] @@ -42,8 +42,8 @@ check-cfg = [ [workspace.dependencies] anyhow = "1.0.102" backtrace = "0.3.76" -foundations = { version = "5.11.1", path = "./foundations", default-features = false } -foundations-macros = { version = "=5.11.1", path = "./foundations-macros", default-features = false } +foundations = { version = "5.11.2", path = "./foundations", default-features = false } +foundations-macros = { version = "=5.11.2", path = "./foundations-macros", default-features = false } foundations-metrics-registry = { version = "1.0.0", path = "./foundations-metrics-registry", default-features = false } foundations-metrics = { version = "0.1.0-beta.4", path = "./foundations-metrics", default-features = false } bindgen = { version = "0.72.1", default-features = false } diff --git a/RELEASE_NOTES.md b/RELEASE_NOTES.md index 016562be..dd2039f6 100644 --- a/RELEASE_NOTES.md +++ b/RELEASE_NOTES.md @@ -1,4 +1,7 @@ +5.11.2 +- 2026-10-26 fix: Allow libc <0.2.190 again for compatibility with quiche + 5.11.1 - 2026-10-19 deps: update libc to 0.2.191 and remove upper bound - 2026-10-15 foundations/derive: add derive to the platform-common-default feature set