From 18fce8794068ff2138ac5ddaa6f58041e2f3b3f3 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Christian=20L=C3=BCck?= Date: Sun, 4 Oct 2026 00:05:28 +0200 Subject: [PATCH] Update build environment from PHP 8.1 to PHP 8.5 --- Dockerfile | 2 +- README.md | 2 +- composer.json | 7 +------ composer.lock | 7 ++----- 4 files changed, 5 insertions(+), 13 deletions(-) diff --git a/Dockerfile b/Dockerfile index ea5eba1..5e76a37 100644 --- a/Dockerfile +++ b/Dockerfile @@ -1,5 +1,5 @@ # base PHP version for the build and final project -FROM php:8.1-apache AS php-version +FROM php:8.5-apache AS php-version # base composer stage to install dependencies FROM composer:2 AS vendor diff --git a/README.md b/README.md index 6ba96cf..36565a9 100644 --- a/README.md +++ b/README.md @@ -9,7 +9,7 @@ Source code for the https://clue.engineering/ website. ### Install -This project has a number of specific system requirements, including PHP 8.1+, +This project has a number of specific system requirements, including PHP 8.5+, Composer, Docker Compose, and others. To ease development, we use Docker containers that include all development diff --git a/composer.json b/composer.json index c866140..a7c4c2e 100644 --- a/composer.json +++ b/composer.json @@ -1,6 +1,6 @@ { "require": { - "php": ">=8.1" + "php": ">=8.5" }, "require-dev": { "sculpin/sculpin": "^3.3.2" @@ -12,10 +12,5 @@ }, "replace": { "sculpin/sculpin-theme-composer-plugin": "1.0.2" - }, - "config": { - "platform": { - "php": "8.1.8" - } } } diff --git a/composer.lock b/composer.lock index ccb5ef8..732756b 100644 --- a/composer.lock +++ b/composer.lock @@ -4,7 +4,7 @@ "Read more about it at https://getcomposer.org/doc/01-basic-usage.md#installing-dependencies", "This file is @generated automatically" ], - "content-hash": "363da0470b70ebd3c113bf61c3911227", + "content-hash": "ffbfc83abc9b16ab232591bbe44b9f51", "packages": [], "packages-dev": [ { @@ -3701,11 +3701,8 @@ "prefer-stable": false, "prefer-lowest": false, "platform": { - "php": ">=8.1" + "php": ">=8.5" }, "platform-dev": {}, - "platform-overrides": { - "php": "8.1.8" - }, "plugin-api-version": "2.9.0" }