| description | Your graph in sheet format |
|---|
Graph Commons Data Table is an efficient tool to view, sort, and edit your graph data as you would do on a spreadsheet. Click on Data button in the toolbar to open the data table.
It is especially useful if you are:
- Used to working with rows and columns: If you are not familiar with network maps or relational data, it can be difficult for you to imagine how data sets can turn into graphs. Using the data table, you can observe this process simultaneously without having to switch screens.
- Revising taxonomy: The data table is the go to place for remodeling your graph. Here you can add, remove or rename whole types or properties, just as well as single nodes or edges.
- Editing specific data points in a large graph: Navigating a graph is great, but if you need to make a series of detailed edits, like node properties and edge weights, tables can come in handy
- In need of partial exports: Each tab of the data table can be exported separately. If you prefer sorting your exports according to type, the data table has it for you.
All its smartness aside, the data table is not a full spreadsheet app. At any point, if you need to copy and paste many lines or use formulas to crunch your data, we recommend going back to an actual Excel/CSV/Google spreadsheet to make use of advanced features.
Pretty similar to a spreadsheet, the data table works in tabs, columns and rows. Before diving into learning all about the data table, give it a try, import a ready-made graph template and view the data table for that graph.
Before creating a node, we have to assign a type to it (Learn more about types). The first button you need to find is the + sign under the title 'Data Table'. Choose Add node type, to open "New node type" dialogue. Enter a type name in this box.
Data Table menu to add types and nodes
If you have data already in your graph, you will see "Add <Type> node" options in the menu to directly add a node of an existing type.
For each data type, you will see a tab, which allows viewing and editing data in a canonical way.
As you edit a node in data table, its data is synchronized in the UI, so for instance you can view its node card with the updated details. If you can't see this node, click on the "Fit to Screen" button at the bottom right, the node should move to the center of the canvas.
A node is selected on Data Table, it is highlighted on canvas, and displayed as node card
You can click any cell and edit its content. Also go to a tab, mouse over its menu to add nodes, add properties, edit type, or delete the entire type with its data.
Tab/type menu with Add node, Add property, Edit, and Delete options
Mouse over a column menu to edit that property name, delete it, or clear its data. You can also insert new column/property before or after it. Finally, you can Sort the entire table alphabetically based on this column.
Column/property menu with Edit, Delete, Clear, Insert column, Sort options
You can select rows (nodes or relationships) and delete them all. Let's delete FTX from this graph!
Select rows and delete all at once
You can export a particular type of nodes or relationships, or all of them as CSV file to open in your Excel or Google Sheets.






