Skip to content

az sql mi update --resource-group rgName --name sqlMiName --admin-password fails with ERROR: (InvalidParameterValue) #32257

Description

Describe the bug

When using v2.78.0 of the cli, the following command:

az sql mi update --resource-group rgName --name sqlMiName --admin-password new-password

fails with:

ERROR: (InvalidParameterValue) Invalid value given for parameter LogicalAvailabilityZone can NOT be specified because ZonePinning feature is NOT yet supported!. Specify a valid parameter value.

This works fine with v2.77.0.

Related command

az sql mi update --resource-group rgName --name sqlMiName --admin-password new-password

Errors

ERROR: (InvalidParameterValue) Invalid value given for parameter LogicalAvailabilityZone can NOT be specified because ZonePinning feature is NOT yet supported!. Specify a valid parameter value.

Issue script & Debug output

n/a

Expected behavior

I expect this to not error.

Environment Summary

azure-cli: 2.78.0

Additional context

No response

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Labels

Auto-AssignAuto assign by botSQLaz sqlService AttentionThis issue is responsible by Azure service team.act-codegen-extensibility-squadbugThis issue requires a change to an existing behavior in the product in order to be resolved.customer-reportedIssues that are reported by GitHub users external to the Azure organization.

Type

No type

Projects

No projects

    Milestone

    No milestone

    Relationships

    None yet

    Development

    No branches or pull requests

    Issue actions