Repository navigation
Octopus install fails with System.Security.Cryptography.CryptographicException #30
Description
Activity
So 1.2.0.11 should definitely have fixed the problem.
When you upgraded did you do an in-place upgrade or provision new servers and vip swap?
It was a in-place upgrade...
I suspect that might be your problem. The stuff that the original bug left behind might still be there. I'd recommend starting with some fresh servers, doing a vip swap and then reporting back if there is still a problem.
Something to note: when you vip swap and spin down the servers it will remove them from octopus unless the new servers have a different name (maybe use the tentacle machine suffix config option?). In the past I've restarted the nodes after I deleted the staging slot and that brought the servers down one by one so the site didn't go down, but in doing so re-registered them with octopus.
I also this have this issue very frequently.
System.Exception: Non-zero exit code returned (100). Stdout: Octopus Deploy: Tentacle version 2.6.5.1010 ------------------------------------------------------------------------------- Error: An exception was thrown while invoking the constructor 'Void .ctor(Octopus.Platform.Deployment.Configuration.IKeyValueStore, Octopus.Platform.Deployment.Configuration.ICommunicationsConfiguration, Octopus.Shared.Security.ICertificateGenerator)' on type 'TentacleConfiguration'. ---> Key not valid for use in specified state. (See inner exception for details.) ------------------------------------------------------------------------------- Full error details are available in the log files. See: http://g.octopushq.com/LogFiles StdErr: at AzureWebFarm.OctopusDeploy.Infrastructure.ProcessRunner.Run(String executable, String arguments)we have done numerous redeployments of these servers. The one thing we haven't freshly redeployed is the Octopus Server, could that be the culprit?
See version of Tentacle above is way after 1.2.0.11 and our server version is Octopus Deploy 2.6.0.778
EDIT:
I just did this a couple of times and it seemed to do it when I was Reimaging. Deleting the deployment and installing it from the a new package upload seemed to work. I also, updated the suffix for each attempt, not sure if that helped me.@daniefvh to clarify - the
1.2.0.11version above was referencing the version of AzureWebFarm.OctopusDeploy - not the version of the installed tentacle.You can tell what version of AzureWebFarm.OctopusDeploy you are on by looking at your packages.config file.
Reported by @mneelakanta via MRCollective/AzureWebFarm#21
This issue was supposed to be fixed in 1.2.0. We are currently using 1.2.0.11 and have encountered this issue a few times over the last 2 months...
Any ideas?