Repository navigation
chore: drop Python 3.8-3.9 support and update dependencies - #29
Closed
fern-api[bot] wants to merge 1 commit into
Closed
fern-api[bot] wants to merge 1 commit into
fern-api[bot] wants to merge 1 commit into
Conversation
Updates minimum Python version from 3.8 to 3.10 and removes support for Python 3.8 and 3.9. Also updates development dependencies to newer versions and adds comprehensive documentation strings for all type aliases to improve developer experience. Key changes: - Drop Python 3.8 and 3.9 support, require Python 3.10+ - Update pytest from ^7.4.0 to ^8.2.0 - Update pytest-asyncio from ^0.23.5 to ^1.0.0 - Add detailed docstrings to all type aliases with usage examples and references 🌿 Generated with Fern
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Version Bump: Dropping Python 3.8 and 3.9 support breaks compatibility for existing users running those versions.
The SDK now requires Python 3.10 or higher. Python 3.8 and 3.9 are no longer supported. All type aliases now include comprehensive documentation with usage examples and links to relevant guides.