Repository navigation
fix(deps): clear Dependabot wave 4 (undici, msal-node, nodemailer, fast-uri, serialize-javascript, sentry) - #211
Merged
Merged
Conversation
…i 4.2.3, serialize-javascript 7.1.4, @sentry/nextjs manifest ^11.9.0 for Dependabot alerts
Dependency Review✅ No vulnerabilities or license issues or OpenSSF Scorecard issues found.OpenSSF Scorecard
Scanned Files
|
Security Scan Results: PASSED
|
PR Checks Summary
✅ All checks passed! Ready for review. |
This file contains hidden or bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment
Add this suggestion to a batch that can be applied as a single commit.This suggestion is invalid because no changes were made to the code.Suggestions cannot be applied while the pull request is closed.Suggestions cannot be applied while viewing a subset of changes.Only one suggestion per line can be applied in a batch.Add this suggestion to a batch that can be applied as a single commit.Applying suggestions on deleted lines is not supported.You must change the existing code in this line in order to create a valid suggestion.Outdated suggestions cannot be applied.This suggestion has been applied or marked resolved.Suggestions cannot be applied from pending reviews.Suggestions cannot be applied on multi-line comments.Suggestions cannot be applied while the pull request is queued to merge.Suggestion cannot be applied right now. Please check back later.
Clears the open Dependabot alerts #493 and #506-#517 by fixing the dependencies.
Changes
undicioverride>=8.12.2(8.10.2 -> 8.12.3): #514-#516@azure/msal-nodenew scoped override@azure/msal-node@<7.1.0 -> >=7.1.0 <8.0.0(5.2.1 -> 7.1.1; only reached through artillery > @azure/identity): #517nodemaileroverride floor>=10.1.4 <11,frontenddep^10.1.4(10.0.14 -> 10.2.1): #510-#512fast-urioverride>=4.2.3 <5(4.2.1 -> 4.2.3): #506-#509serialize-javascriptoverride>=7.1.3(7.0.5 -> 7.1.4): #513@sentry/nextjs:frontend/package.jsonstill declared10.49.0(the vulnerable range Dependabot reads); main already resolved 11.9.0 through the override. Manifest now^11.9.0, lockfile resolution unchanged (#493).Lockfile: regenerated with
pnpm@9.15.4 install --lockfile-only; diff is the targeted bumps plus an appium@appium/logger2.0.7 -> 2.0.11 peer-suffix dedupe. No package version bumps, no tags.Verification
pnpm install --frozen-lockfile: okpnpm audit --audit-level=high: 1 high remaining, already in the ignore list (http-cache-semantics, no fix); none of the targeted packagesosv-scanner pnpm-lock.yaml: targeted packages gone. Remaining, not in this PR: @tiptap/core 2.27.3, csv-parse 4.16.3, stream-json 1.9.1, http-cache-semantics 4.2.0pnpm -r type-check: 169 TS errors in frontend-vite (unbuilt@nself/ui/@nself/auth-core), identical count on clean origin/main;frontendtype-check 0 errors on bothAlready red on main (not touched)
Unit Tests / Type Check / coverage gates (hq quality/debt.yaml D-1475).