Skip to content

Huggingface won't install on clusters with the Monitoring addon disabled #116

Description

@AlexCK-STFC

azimuth-chat (HuggingFace LLM Kubernetes app) gives Error: unable to build kubernetes objects from release manifest: resource mapping not found for name: "test-llm-no-monit" namespace: "" from "": no matches for kind "ServiceMonitor" in version "[monitoring.coreos.com/v1](http://monitoring.coreos.com/v1)" ensure CRDs are installed first when trying to install on clusters with the Cluster Monitoring cluster addon disabled.

Can this be solved without disabling the ServiceMonitor altogether; i.e. by detecting if the Monitoring cluster addon is enabled first and setting .Values.api.monitoring.enabled?

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions